Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Advisories: GSA_kwCzR0hTQS1qbWo2LXAyajktNjhjcM4AAw90

Wildfly-elytron possibly vulnerable to timing attacks via use of unsafe comparator

wildfly-elytron: possible timing attacks via use of unsafe comparator. A flaw was found in Wildfly-elytron. Wildfly-elytron uses java.util.Arrays.equals in several places, which is unsafe and vulnerable to timing attacks. To compare values securely, use java.security.MessageDigest.isEqual instead. This flaw allows an attacker to access secure information or impersonate an authed user.

Permalink: https://github.com/advisories/GHSA-jmj6-p2j9-68cp

Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: 16 days ago
Updated: 3 days ago

CVSS Score: 7.4
CVSS vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Identifiers: GHSA-jmj6-p2j9-68cp, CVE-2022-3143
References:

Affected Packages

maven:org.wildfly.security:wildfly-elytron
Versions: >= 1.16.0.CR1, < 1.20.3.Final, < 1.15.15.Final
Fixed in: 1.20.3.Final, 1.15.15.Final