Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1qcnFoLWM5djgtY2N4Oc4AAu-e

Path traversal in Jenkins build-publisher Plugin

Jenkins Build-Publisher Plugin 1.22 and earlier allows attackers with Item/Configure permission to create or replace any config.xml file on the Jenkins controller file system by providing a crafted file name to an API endpoint. Additionally, this endpoint does not require POST requests, resulting in a cross-site request forgery (CSRF) vulnerability that allows attackers to replace any config.xml file on the Jenkins controller file system with an empty file.

There is currently no known workaround or fix, and this plugin has been suspended.

Permalink: https://github.com/advisories/GHSA-jrqh-c9v8-ccx9
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1qcnFoLWM5djgtY2N4Oc4AAu-e
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: almost 2 years ago
Updated: over 1 year ago


CVSS Score: 5.7
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N

Identifiers: GHSA-jrqh-c9v8-ccx9, CVE-2022-41231
References: Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:build-publisher
Affected Version Ranges: <= 1.22
No known fixed version