Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1tM3AzLTJncDYtZ2hxOM06vA

Stored Cross-site Scripting vulnerability in Jenkins Jira Plugin

Jenkins Jira Plugin 3.7 and earlier, except 3.6.1, does not escape the name and description of Jira Issue and Jira Release Version parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.

Exploitation of this vulnerability requires that parameters are listed on another page, like the "Build With Parameters" and "Parameters" pages provided by Jenkins (core), and that those pages are not hardened to prevent exploitation. Jenkins (core) has prevented exploitation of vulnerabilities of this kind on the "Build With Parameters" and "Parameters" pages since 2.44 and LTS 2.32.2 as part of the SECURITY-353 / CVE-2017-2601 fix.

Permalink: https://github.com/advisories/GHSA-m3p3-2gp6-ghq8
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1tM3AzLTJncDYtZ2hxOM06vA
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: 9 months ago


CVSS Score: 5.4
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-m3p3-2gp6-ghq8, CVE-2022-29041
References: Repository: https://github.com/jenkinsci/jira-plugin
Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:jira
Affected Version Ranges: < 3.6.1, >= 3.7.0, < 3.7.1
Fixed in: 3.6.1, 3.7.1