Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1tNWN3LWM2NHAtNzdoNs06pQ

CSRF vulnerability in Jenkins Subversion Plugin

Subversion Plugin 2.15.3 and earlier does not require POST requests for several form validation methods, resulting in cross-site request forgery (CSRF) vulnerabilities.

These vulnerabilities allow attackers to connect to an attacker-specified URL.

Permalink: https://github.com/advisories/GHSA-m5cw-c64p-77h6
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1tNWN3LWM2NHAtNzdoNs06pQ
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: 7 months ago


CVSS Score: 4.3
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Identifiers: GHSA-m5cw-c64p-77h6, CVE-2022-29048
References: Repository: https://github.com/jenkinsci/subversion-plugin
Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:subversion
Affected Version Ranges: < 2.15.4
Fixed in: 2.15.4