Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1tZmp3LXg0cTQtNjlwOc4AAigf

Ignite Realtime Openfire vulnerable to Server Side Request Forgery

A Server Side Request Forgery (SSRF) vulnerability in FaviconServlet.java in Ignite Realtime Openfire through 4.4.2 allows attackers to send arbitrary HTTP GET requests. The issue is fixed in version 4.5.0-beta.

Permalink: https://github.com/advisories/GHSA-mfjw-x4q4-69p9
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1tZmp3LXg0cTQtNjlwOc4AAigf
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: almost 2 years ago
Updated: about 1 year ago


CVSS Score: 9.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-mfjw-x4q4-69p9, CVE-2019-18394
References:

Affected Packages

maven:org.igniterealtime.openfire:parent
Versions: < 4.5.0-beta
Fixed in: 4.5.0-beta