An open API service providing security vulnerability metadata for many open source software ecosystems.
Security Advisories: GSA_kwCzR0hTQS1tZzQ2LWY5aDUtZzI3eM4AAywe
Apache Sling Engine vulnerable to cross-site scripting (XSS) that can lead to privilege escalation
The SlingRequestDispatcher doesn't correctly implement the RequestDispatcher API resulting in a generic type of include-based cross-site scripting issues on the Apache Sling level. The vulnerability is exploitable by an attacker that is able to include a resource with specific content-type and control the include path (i.e. writing content). The impact of a successful attack is privilege escalation to administrative power.
Please update to Apache Sling Engine version 2.14.0 or newer and enable the "Check Content-Type overrides" configuration option.Permalink: https://github.com/advisories/GHSA-mg46-f9h5-g27x
Source: GitHub Advisory Database
Published: 8 months ago
Updated: 8 months ago
CVSS Score: 8.0
CVSS vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
Identifiers: GHSA-mg46-f9h5-g27x, CVE-2022-45064
Fixed in: 2.14.0