Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1tamd3LWYyYzQtZjhxas4AAwzj

WebPA SQL Injection vulnerability

A vulnerability was found in WebPA up to 3.1.1. It has been rated as critical. This issue affects some unknown processing. The manipulation leads to sql injection. Upgrading to version 3.1.2 can to address this issue. The name of the patch is 8836c4f549181e885a68e0e7ca561fdbcbd04bf0. It is recommended to upgrade the affected component. The identifier VDB-217637 was assigned to this vulnerability.

Permalink: https://github.com/advisories/GHSA-mjgw-f2c4-f8qj
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1tamd3LWYyYzQtZjhxas4AAwzj
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: over 1 year ago
Updated: 9 months ago


CVSS Score: 9.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-mjgw-f2c4-f8qj, CVE-2021-4308
References: Repository: https://github.com/WebPA/WebPA
Blast Radius: 1.0

Affected Packages

packagist:webpa/webpa
Dependent packages: 0
Dependent repositories: 0
Downloads: 309 total
Affected Version Ranges: < 3.1.2
Fixed in: 3.1.2
All affected versions: 3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.0.4, 3.0.5, 3.0.6, 3.0.7, 3.1.0, 3.1.1
All unaffected versions: 3.1.2, 3.2.0, 3.2.1, 3.2.2