Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1tcWY4LTRjcW0tcDgzeM4AA5J6

Liferay Portal allows attackers to discover the existence of sites

Liferay Portal 7.2.0 through 7.4.1, and older unsupported versions, and Liferay DXP 7.3 before service pack 3, 7.2 before fix pack 18, and older unsupported versions returns with different responses depending on whether a site does not exist or if the user does not have permission to access the site, which allows remote attackers to discover the existence of sites by enumerating URLs. This vulnerability occurs if locale.prepend.friendly.url.style=2 and if a custom 404 page is used.

Permalink: https://github.com/advisories/GHSA-mqf8-4cqm-p83x
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1tcWY4LTRjcW0tcDgzeM4AA5J6
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: 22 days ago
Updated: 15 days ago


CVSS Score: 5.3
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Identifiers: GHSA-mqf8-4cqm-p83x, CVE-2024-25146
References:

Affected Packages

maven:com.liferay.portal:release.dxp.bom
Versions: >= 7.2.0, < 7.2.10.fp18, >= 7.3.0, < 7.3.10.u4
Fixed in: 7.2.10.fp18, 7.3.10.u4
maven:com.liferay.portal:release.portal.bom
Versions: >= 7.2.0, < 7.4.2
Fixed in: 7.4.2