Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1tcmNqLTVxeHItdmhwMs4AA0Jz

angular-ui-notification Cross-site Scripting vulnerability

angular-ui-notification v0.1.0, v0.2.0, and v0.3.6 was discovered to contain a cross-site scripting (XSS) vulnerability.

Permalink: https://github.com/advisories/GHSA-mrcj-5qxr-vhp2
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1tcmNqLTVxeHItdmhwMs4AA0Jz
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: 10 months ago
Updated: 5 months ago


CVSS Score: 6.1
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-mrcj-5qxr-vhp2, CVE-2023-34840
References: Repository: https://github.com/Xh4H/CVE-2023-34840
Blast Radius: 16.1

Affected Packages

npm:angular-ui-notification
Dependent packages: 12
Dependent repositories: 429
Downloads: 28,835 last month
Affected Version Ranges: >= 0.1.0, <= 0.3.6
No known fixed version
All affected versions: 0.1.0, 0.2.0, 0.3.5, 0.3.6