Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1wMjVtLWpwajQtcWNycs4AA127

Denial of Service Vulnerability in gRPC TCP Server (Posix-compatible platforms)

Lack of error handling in the TCP server in Google's gRPC starting version 1.23 on posix-compatible platforms (ex. Linux) allows an attacker to cause a denial of service by initiating a significant number of connections with the server. Note that gRPC C++ Python, and Ruby are affected, but gRPC Java, and Go are NOT affected. 

Permalink: https://github.com/advisories/GHSA-p25m-jpj4-qcrr
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1wMjVtLWpwajQtcWNycs4AA127
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: 5 months ago
Updated: 11 days ago


CVSS Score: 7.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Identifiers: GHSA-p25m-jpj4-qcrr, CVE-2023-4785
References:

Affected Packages

pypi:grpcio
Versions: >= 1.53.0, < 1.53.2, >= 1.54.0, < 1.54.3, >= 1.55.0, < 1.55.3
Fixed in: 1.53.2, 1.54.3, 1.55.3
rubygems:grpc
Versions: >= 1.53.0, < 1.53.2, >= 1.54.0, < 1.54.3, >= 1.55.0, < 1.55.3, >= 1.56.0, < 1.56.2
Fixed in: 1.53.2, 1.54.3, 1.55.3, 1.56.2