Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1wMzdwLXdnOTItMmZjNM4AAu-P

Missing permission checks in Jenkins CONS3RT Plugin allow enumerating credentials IDs

CONS3RT Plugin 1.0.0 and earlier does not perform permission checks in several HTTP endpoints.

This allows attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins. Those can be used as part of an attack to capture the credentials using another vulnerability.

Permalink: https://github.com/advisories/GHSA-p37p-wg92-2fc4
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1wMzdwLXdnOTItMmZjNM4AAu-P
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: over 1 year ago
Updated: over 1 year ago


CVSS Score: 4.3
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Identifiers: GHSA-p37p-wg92-2fc4, CVE-2022-41252
References: Blast Radius: 1.0

Affected Packages

maven:org.jenkins-ci.plugins:cons3rt
Affected Version Ranges: <= 1.0.0
No known fixed version