Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1wNXE5LTg2dzQtMnhyNc4AA5iD

SMTP smuggling in Apache James

Apache James prior to versions 3.8.1 and 3.7.5 is vulnerable to SMTP smuggling.

A lenient behaviour in line delimiter handling might create a difference of interpretation between the sender and the receiver which can be exploited by an attacker to forge an SMTP envelop, allowing for instance to bypass SPF checks.

The patch implies enforcement of CRLF as a line delimiter as part of the DATA transaction.

We recommend James users to upgrade to non vulnerable versions.

Permalink: https://github.com/advisories/GHSA-p5q9-86w4-2xr5
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1wNXE5LTg2dzQtMnhyNc4AA5iD
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 months ago
Updated: about 2 months ago


Identifiers: GHSA-p5q9-86w4-2xr5, CVE-2023-51747
References: Repository: https://github.com/apache/james-project
Blast Radius: 0.0

Affected Packages

maven:org.apache.james:james-server
Dependent packages: 1
Dependent repositories: 15
Downloads:
Affected Version Ranges: = 3.8.0, < 3.7.5
Fixed in: 3.8.1, 3.7.5
All affected versions: 3.0.0, 3.0.1, 3.1.0, 3.2.0, 3.3.0, 3.4.0, 3.5.0, 3.6.0, 3.6.2, 3.7.0, 3.7.1, 3.7.2, 3.7.3, 3.7.4, 3.8.0
All unaffected versions: 3.7.5, 3.8.1