Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1wNmZoLXhjNnItZzVod84AAvFp

Brokercap Bifrost subject to authentication bypass when using HTTP basic authentication

Bifrost is a middleware package which can synchronize MySQL/MariaDB binlog data to other types of databases. Versions 1.8.6-release and prior are vulnerable to authentication bypass when using HTTP basic authentication. This may allow group members who only have read permissions to write requests when they are normally forbidden from doing so. Version 1.8.7-release contains a patch. There are currently no known workarounds.

Permalink: https://github.com/advisories/GHSA-p6fh-xc6r-g5hw
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1wNmZoLXhjNnItZzVod84AAvFp
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: almost 2 years ago
Updated: over 1 year ago


CVSS Score: 8.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:L

Identifiers: GHSA-p6fh-xc6r-g5hw, CVE-2022-39219
References: Repository: https://github.com/brokercap/Bifrost
Blast Radius: 0.0

Affected Packages

go:github.com/brokercap/Bifrost
Dependent packages: 0
Dependent repositories: 1
Downloads:
Affected Version Ranges: <= 1.8.6-release
Fixed in: 1.8.7-release
All affected versions: 1.1.0, 1.2.2, 1.8.6-release
All unaffected versions: