Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1wODN2LTh2bXItcWZ2Oc4AAUVh

Sylabs Singularity Improper Input Validation

Sylabs Singularity 2.4 to 2.6 allows local users to conduct Improper Input Validation attacks.

Permalink: https://github.com/advisories/GHSA-p83v-8vmr-qfv9
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1wODN2LTh2bXItcWZ2Oc4AAUVh
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 2 years ago
Updated: 8 months ago


CVSS Score: 7.8
CVSS vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-p83v-8vmr-qfv9, CVE-2018-19295
References: Repository: https://github.com/sylabs/singularity
Blast Radius: 7.0

Affected Packages

go:github.com/sylabs/singularity
Dependent packages: 3
Dependent repositories: 8
Downloads:
Affected Version Ranges: >= 2.4.0, < 2.6.1
Fixed in: 2.6.1
All affected versions:
All unaffected versions: 3.0.0, 3.0.1, 3.0.2, 3.0.3, 3.1.0, 3.1.1