Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1wajQ1LTh2aGMtbWgyZs4AAXb9

Jenkins Swarm Plugin Client vulnerable to man-in-the-middle attacks

Jenkins Swarm Plugin Client 3.4 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks.

Permalink: https://github.com/advisories/GHSA-pj45-8vhc-mh2f
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1wajQ1LTh2aGMtbWgyZs4AAXb9
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 1 year ago
Updated: 4 months ago


CVSS Score: 5.9
CVSS vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

Identifiers: GHSA-pj45-8vhc-mh2f, CVE-2017-1000402
References:

Affected Packages

maven:org.jvnet.hudson.plugins:swarm-plugin
Versions: <= 1.5
No known fixed version
maven:org.jenkins-ci.plugins:swarm-client
Versions: <= 3.4
Fixed in: 3.5