Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1wcDNjLWNmNmotbTNmZs4AArZm

Server-Side Request Forgery in Jodd HTTP

Jodd HTTP v6.0.9 was discovered to contain multiple CLRF injection vulnerabilities via the components jodd.http.HttpRequest#set and `jodd.http.HttpRequest#send. These vulnerabilities allow attackers to execute Server-Side Request Forgery (SSRF) via a crafted TCP payload.

Permalink: https://github.com/advisories/GHSA-pp3c-cf6j-m3ff
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1wcDNjLWNmNmotbTNmZs4AArZm
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: almost 2 years ago
Updated: over 1 year ago


CVSS Score: 7.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Identifiers: GHSA-pp3c-cf6j-m3ff, CVE-2022-29631
References: Repository: https://github.com/oblac/jodd-http
Blast Radius: 19.1

Affected Packages

maven:org.jodd:jodd-http
Dependent packages: 133
Dependent repositories: 356
Downloads:
Affected Version Ranges: >= 5.0.0, < 6.2.1
Fixed in: 6.2.1
All affected versions: 5.0.0, 5.0.1, 5.0.2, 5.0.3, 5.0.4, 5.0.5, 5.0.6, 5.0.7, 5.0.8, 5.0.9, 5.0.10, 5.0.11, 5.0.12, 5.0.13, 5.1.0, 5.1.2, 5.1.3, 5.1.4, 5.1.5, 5.1.6, 5.2.0, 6.0.1, 6.0.2, 6.0.3, 6.0.4, 6.0.5, 6.0.6, 6.0.7, 6.0.8, 6.0.9, 6.1.0, 6.2.0
All unaffected versions: 3.4.0, 3.4.1, 3.4.2, 3.4.3, 3.4.4, 3.4.5, 3.4.7, 3.4.8, 3.4.9, 3.4.10, 3.5.1, 3.5.2, 3.6.1, 3.6.2, 3.6.3, 3.6.4, 3.6.5, 3.6.6, 3.6.7, 3.6.8, 3.7.1, 3.8.0, 3.8.1, 3.8.5, 3.8.6, 3.9.1, 4.0.0, 4.1.0, 4.1.1, 4.1.2, 4.1.3, 4.1.4, 4.1.5, 4.2.0, 4.3.0, 4.3.1, 4.3.2, 6.2.1, 6.3.0