Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1wdjRjLXJqNGgtZ3I5bc4AAi-1

Jenkins Alauda DevOps Pipeline Plugin vulnerable to cross-site request forgery

A cross-site request forgery vulnerability in Jenkins Alauda DevOps Pipeline Plugin 2.3.2 and earlier allows attackers to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

Permalink: https://github.com/advisories/GHSA-pv4c-rj4h-gr9m
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1wdjRjLXJqNGgtZ3I5bc4AAi-1
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 2 years ago
Updated: over 1 year ago


CVSS Score: 8.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Identifiers: GHSA-pv4c-rj4h-gr9m, CVE-2019-16573
References: Blast Radius: 1.0

Affected Packages

maven:com.alauda.jenkins.plugins:alauda-devops-pipeline
Affected Version Ranges: <= 2.3.2
No known fixed version