Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1xNHE1LWM1Y3YtMnA2OM4AAu6M

Vuetify Cross-site Scripting vulnerability

The package vuetify from 2.0.0-beta.4 and before 2.6.10 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization in the 'eventName' function within the VCalendar component.

Permalink: https://github.com/advisories/GHSA-q4q5-c5cv-2p68
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1xNHE1LWM1Y3YtMnA2OM4AAu6M
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 1 year ago
Updated: 8 months ago


CVSS Score: 5.4
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

Identifiers: GHSA-q4q5-c5cv-2p68, CVE-2022-25873
References:

Affected Packages

maven:org.webjars.npm:vuetify
Versions: >= 2.0.0-beta.4, < 2.6.10
Fixed in: 2.6.10
npm:vuetify
Versions: >= 2.0.0-beta.4, < 2.6.10
Fixed in: 2.6.10