Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1xNTZoLWpqajYtNTJtZs4AAZnl

Improper Restriction of XML External Entity Reference in Apache POI

The OPC SAX setup in Apache POI before 3.10.1 allows remote attackers to read arbitrary files via an OpenXML file containing an XML external entity declaration in conjunction with an entity reference, related to an XML External Entity (XXE) issue.

Permalink: https://github.com/advisories/GHSA-q56h-jjj6-52mf
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1xNTZoLWpqajYtNTJtZs4AAZnl
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: about 1 month ago


Identifiers: GHSA-q56h-jjj6-52mf, CVE-2014-3529
References: Repository: https://github.com/apache/poi
Blast Radius: 0.0

Affected Packages

maven:org.apache.poi:poi
Dependent packages: 2,109
Dependent repositories: 75,041
Downloads:
Affected Version Ranges: < 3.10.1
Fixed in: 3.10.1
All affected versions:
All unaffected versions: 3.10.1, 4.0.0, 4.0.1, 4.1.0, 4.1.1, 4.1.2, 5.0.0, 5.1.0, 5.2.0, 5.2.1, 5.2.2, 5.2.3, 5.2.4, 5.2.5