Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1xNWo5LWY5NXctZjRwcs4AAwIx

TERASOLUNA Server Framework vulnerable to ClassLoader manipulation

TERASOLUNA Global Framework 1.0.0 (Public review version) and TERASOLUNA Server Framework for Java (Rich) 2.0.0.2 to 2.0.5.1 are vulnerable to ClassLoader manipulation due to using the old version of Spring Framework which contains the vulnerability. The vulnerability is caused by an improper input validation issue in the binding mechanism of Spring MVC. By the application processing a specially crafted file, arbitrary code may be executed with the privileges of the application.

When using TERASOLUNA Global Framework 1.0.0 (Public review version), update to TERASOLUNA Server Framework for Java 5.7.1.SP1 (using Spring Framework 5.3.18). This vulnerability alone can be addressed by updating to TERASOLUNA Global Framework 1.0.1 (using Spring Framework 3.2.10) or later.

Permalink: https://github.com/advisories/GHSA-q5j9-f95w-f4pr
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1xNWo5LWY5NXctZjRwcs4AAwIx
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 1 year ago
Updated: over 1 year ago


CVSS Score: 7.8
CVSS vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Identifiers: GHSA-q5j9-f95w-f4pr, CVE-2022-43484
References: Repository: https://github.com/spring-projects/spring-framework
Blast Radius: 8.9

Affected Packages

maven:org.terasoluna.gfw:terasoluna-gfw-common
Dependent packages: 8
Dependent repositories: 14
Downloads:
Affected Version Ranges: < 1.0.1.RELEASE
Fixed in: 1.0.1.RELEASE
All affected versions:
All unaffected versions: