Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1xNzk5LXEyN3gtdnA3d80WOg

Out-of-bounds Write in OpenCV

An exploitable heap buffer overflow vulnerability exists in the data structure persistence functionality of OpenCV, version 4.1.0 (corresponds with OpenCV-Python version 4.1.2.30). A specially crafted JSON file can cause a buffer overflow, resulting in multiple heap corruptions and potentially code execution. An attacker can provide a specially crafted file to trigger this vulnerability.

Permalink: https://github.com/advisories/GHSA-q799-q27x-vp7w
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1xNzk5LXEyN3gtdnA3d80WOg
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 2 years ago
Updated: about 1 year ago


CVSS Score: 8.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Identifiers: GHSA-q799-q27x-vp7w, CVE-2019-5064
References: Repository: https://github.com/opencv/opencv
Blast Radius: 42.5

Affected Packages

pypi:opencv-contrib-python-headless
Dependent packages: 50
Dependent repositories: 618
Downloads: 412,710 last month
Affected Version Ranges: <= 4.1.2.30
Fixed in: 4.2.0.32
All affected versions:
All unaffected versions:
pypi:opencv-contrib-python
Dependent packages: 321
Dependent repositories: 8,355
Downloads: 2,015,636 last month
Affected Version Ranges: <= 4.1.2.30
Fixed in: 4.2.0.32
All affected versions:
All unaffected versions:
pypi:opencv-python-headless
Dependent packages: 558
Dependent repositories: 9,646
Downloads: 5,566,640 last month
Affected Version Ranges: <= 4.1.2.30
Fixed in: 4.2.0.32
All affected versions:
All unaffected versions:
pypi:opencv-python
Dependent packages: 3,545
Dependent repositories: 67,670
Downloads: 13,752,551 last month
Affected Version Ranges: <= 4.1.2.30
Fixed in: 4.2.0.32
All affected versions:
All unaffected versions: 3.1.0