Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1xOWc1LTk4cG0tdzZxN84AAVU1

Cobbler XSS Vulnerability

Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Cross Site Scripting (XSS) vulnerability in cobbler-web that can result in Privilege escalation to admin.. This attack appear to be exploitable via "network connectivity". Sending unauthenticated JavaScript payload to the Cobbler XMLRPC API (/cobbler_api).

Permalink: https://github.com/advisories/GHSA-q9g5-98pm-w6q7
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1xOWc1LTk4cG0tdzZxN84AAVU1
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: 8 months ago


CVSS Score: 6.1
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-q9g5-98pm-w6q7, CVE-2018-1000225
References: Repository: https://github.com/cobbler/cobbler
Blast Radius: 6.4

Affected Packages

pypi:cobbler
Dependent packages: 0
Dependent repositories: 11
Downloads: 299 last month
Affected Version Ranges: <= 2.6.11
No known fixed version
All affected versions: