Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1xcWZjLW05aGMtcHF2M84AARGl

Deserialization of Untrusted Data in Infinispan

Infinispan permits improper deserialization of trusted data via XML and JSON transcoders under certain server configurations. A user with authenticated access to the server could send a malicious object to a cache configured to accept certain types of objects, achieving code execution and possible further attacks. Versions 9.0.3.Final, 9.1.7.Final, 8.2.10.Final, 9.2.2.Final, 9.3.0.Alpha1 are believed to be affected.

Permalink: https://github.com/advisories/GHSA-qqfc-m9hc-pqv3
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1xcWZjLW05aGMtcHF2M84AARGl
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: almost 2 years ago
Updated: about 1 year ago


CVSS Score: 8.8
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-qqfc-m9hc-pqv3, CVE-2018-1131
References: Blast Radius: 31.8

Affected Packages

maven:org.infinispan:infinispan-core
Dependent packages: 543
Dependent repositories: 4,067
Downloads:
Affected Version Ranges: = 9.3.0.Alpha1, = 9.2.2.Final, = 9.1.7.Final, = 9.0.3.Final, = 8.2.10.Final
Fixed in: 9.3.1.Final, , , ,
All affected versions: 8.2.1-0.Final
All unaffected versions: