Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1xd2o4LXFncHItOGNybc4AA5J7

Liferay Portal vulnerable to user impersonation

In Liferay Portal 7.2.0 through 7.4.1, and older unsupported versions, and Liferay DXP 7.3 before service pack 3, 7.2 before fix pack 15, and older unsupported versions the doAsUserId URL parameter may get leaked when creating linked content using the WYSIWYG editor and while impersonating a user. This may allow remote authenticated users to impersonate a user after accessing the linked content.

Permalink: https://github.com/advisories/GHSA-qwj8-qgpr-8crm
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1xd2o4LXFncHItOGNybc4AA5J7
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: 22 days ago
Updated: 15 days ago


CVSS Score: 8.1
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Identifiers: GHSA-qwj8-qgpr-8crm, CVE-2024-25148
References:

Affected Packages

maven:com.liferay.portal:release.dxp.bom
Versions: >= 7.3.0, < 7.3.10.u4, >= 7.2.0, < 7.2.10.fp15
Fixed in: 7.3.10.u4, 7.2.10.fp15
maven:com.liferay.portal:release.portal.bom
Versions: >= 7.2.0, < 7.4.2
Fixed in: 7.4.2