Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1yM3I1LWpodzYtNDYzNM05bw

Insecure temporary file usage in SWHKD

SWHKD 1.1.5 unsafely uses the /tmp/swhkd.sock pathname. There can be an information leak or denial of service.

Permalink: https://github.com/advisories/GHSA-r3r5-jhw6-4634
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1yM3I1LWpodzYtNDYzNM05bw
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: about 2 years ago
Updated: over 1 year ago


CVSS Score: 9.1
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Identifiers: GHSA-r3r5-jhw6-4634, CVE-2022-27818
References: Repository: https://github.com/waycrate/swhkd
Blast Radius: 1.0

Affected Packages

cargo:Simple-Wayland-HotKey-Daemon
Dependent packages: 0
Dependent repositories: 0
Downloads: 1,829 total
Affected Version Ranges: < 1.2.0
Fixed in: 1.2.0
All affected versions: 1.1.2, 1.1.3, 1.1.4, 1.1.5
All unaffected versions: 1.2.0