Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1yYzU4LXFyOWotY3Bnd84AAwbo

Apache Airflow Hive Provider vulnerable to Command Injection

Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache Software Foundation Apache Airflow Hive Provider.This issue affects Apache Airflow Hive Provider before 5.0.0.

Permalink: https://github.com/advisories/GHSA-rc58-qr9j-cpgw
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1yYzU4LXFyOWotY3Bnd84AAwbo
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: over 1 year ago
Updated: over 1 year ago


CVSS Score: 9.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-rc58-qr9j-cpgw, CVE-2022-46421
References: Repository: https://github.com/apache/airflow
Blast Radius: 12.5

Affected Packages

pypi:apache-airflow-providers-apache-hive
Dependent packages: 8
Dependent repositories: 19
Downloads: 148,504 last month
Affected Version Ranges: < 5.0.0
Fixed in: 5.0.0
All affected versions: 1.0.0, 1.0.1, 1.0.2, 1.0.3, 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.1.0, 2.2.0, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 3.0.0, 3.1.0, 4.0.0, 4.0.1, 4.1.0, 4.1.1
All unaffected versions: 5.0.0, 5.1.0, 5.1.1, 5.1.2, 5.1.3, 6.0.0, 6.1.0, 6.1.1, 6.1.2, 6.1.3, 6.1.4, 6.1.5, 6.1.6, 6.2.0, 6.3.0, 6.4.0, 6.4.1, 6.4.2, 7.0.0, 7.0.1, 8.0.0, 8.1.0