Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1yYzdoLXg2Y3EtOTg4cc3p0Q

Improper Input Validation in JGroups

JGroups before 4.0 does not require the proper headers for the ENCRYPT and AUTH protocols from nodes joining the cluster, which allows remote attackers to bypass security restrictions and send and receive messages within the cluster via unspecified vectors. Fixes for this issue have been backported to versions 3.6.10.Final and 3.2.16.Final.

Permalink: https://github.com/advisories/GHSA-rc7h-x6cq-988q
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1yYzdoLXg2Y3EtOTg4cc3p0Q
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: about 2 years ago
Updated: about 1 year ago


CVSS Score: 9.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-rc7h-x6cq-988q, CVE-2016-2141
References: Repository: https://github.com/belaban/JGroups
Blast Radius: 32.2

Affected Packages

maven:org.jgroups:jgroups
Dependent packages: 271
Dependent repositories: 1,915
Downloads:
Affected Version Ranges: < 3.2.16.Final, >= 3.3.0.Alpha1, < 3.6.10.Final
Fixed in: 3.2.16.Final, 3.6.10.Final
All affected versions: 3.2.1-0.Final, 3.2.1-1.Final, 3.2.1-2.Final, 3.2.1-3.Final
All unaffected versions: