Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1yZjNmLTNwMzctMnFoNM4AAumL

python-scciclient vulnerable to Man-in-the-middle (MITM) attacks

A flaw was found in the python-scciclient when making an HTTPS connection to a server where the server's certificate would not be verified. This issue opens up the connection to possible Man-in-the-middle (MITM) attacks.

Permalink: https://github.com/advisories/GHSA-rf3f-3p37-2qh4
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1yZjNmLTNwMzctMnFoNM4AAumL
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 1 year ago
Updated: over 1 year ago


CVSS Score: 7.4
CVSS vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Identifiers: GHSA-rf3f-3p37-2qh4, CVE-2022-2996
References: Blast Radius: 7.7

Affected Packages

pypi:python-scciclient
Dependent packages: 0
Dependent repositories: 11
Downloads: 3,438 last month
Affected Version Ranges: < 0.12.0
Fixed in: 0.12.0
All affected versions: 0.0.1, 0.1.0, 0.2.0, 0.3.0, 0.3.1, 0.4.0, 0.5.0, 0.6.0, 0.6.1, 0.6.2, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.7.4, 0.8.0, 0.8.1, 0.8.2, 0.8.3, 0.9.0, 0.9.1, 0.9.2, 0.9.3, 0.9.4, 0.9.5, 0.10.0, 0.10.1, 0.10.2, 0.11.1, 0.11.2, 0.11.3, 0.11.4
All unaffected versions: 0.12.0, 0.12.1, 0.12.2, 0.12.3, 0.13.0, 0.14.0, 0.15.0, 0.16.0