Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1yaDNtLXByMzYteGgyZs4AAwzQ

kelvinmo simplexrd vulnerable to Improper Restriction of XML External Entity Reference

A vulnerability classified as problematic was found in kelvinmo simplexrd up to 3.1.0. This vulnerability affects unknown code of the file simplexrd/simplexrd.class.php. The manipulation leads to xml external entity reference. Upgrading to version 3.1.1 is able to address this issue. The name of the patch is 4c9f2e028523ed705b555eca2c18c64e71f1a35d. It is recommended to upgrade the affected component. VDB-217630 is the identifier assigned to this vulnerability.

Permalink: https://github.com/advisories/GHSA-rh3m-pr36-xh2f
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1yaDNtLXByMzYteGgyZs4AAwzQ
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: over 1 year ago
Updated: 9 months ago


CVSS Score: 9.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-rh3m-pr36-xh2f, CVE-2015-10029
References: Repository: https://github.com/kelvinmo/simplexrd
Blast Radius: 7.6

Affected Packages

packagist:kelvinmo/simplexrd
Dependent packages: 0
Dependent repositories: 6
Downloads: 2,726 total
Affected Version Ranges: < 3.1.1
Fixed in: 3.1.1
All affected versions:
All unaffected versions: 3.1.1, 3.2.1