Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1yajRwLTdtbTYtZ205as4AARto

JBossWS vulnerable to uncontrolled recursion

DOMUtils.java in org.jboss.ws:jbossws-common does not properly handle recursion during entity expansion, which allows remote attackers to cause a denial of service (memory and CPU consumption) via a crafted request containing an XML document with a DOCTYPE declaration and a large number of nested entity references, a similar issue to CVE-2003-1564.

Permalink: https://github.com/advisories/GHSA-rj4p-7mm6-gm9j
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1yajRwLTdtbTYtZ205as4AARto
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Low
Classification: General
Published: about 2 years ago
Updated: over 1 year ago


Identifiers: GHSA-rj4p-7mm6-gm9j, CVE-2011-1483
References: Blast Radius: 0.0

Affected Packages

maven:org.jboss.ws:jbossws-common
Dependent packages: 109
Dependent repositories: 84
Downloads:
Affected Version Ranges: < 2.1.0.Final
Fixed in: 2.1.0.Final
All affected versions:
All unaffected versions: