Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1yajc2LWg4N3AtcjN3Zs4AARX2

Undertow vulnerable to Request Smuggling

In Undertow 2.x before 2.0.0.Alpha2, 1.4.x before 1.4.17.Final, and 1.3.x before 1.3.31.Final, it was found that the fix for CVE-2017-2666 was incomplete and invalid characters are still allowed in the query string and path parameters. This could be exploited, in conjunction with a proxy that also permitted the invalid characters but with a different interpretation, to inject data into the HTTP response. By manipulating the HTTP response the attacker could poison a web-cache, perform an XSS attack, or obtain sensitive information from requests other than their own.

Permalink: https://github.com/advisories/GHSA-rj76-h87p-r3wf
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1yajc2LWg4N3AtcjN3Zs4AARX2
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: about 2 years ago
Updated: over 1 year ago


CVSS Score: 6.1
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Identifiers: GHSA-rj76-h87p-r3wf, CVE-2017-7559
References: Blast Radius: 22.7

Affected Packages

maven:io.undertow:undertow-core
Dependent packages: 912
Dependent repositories: 5,259
Downloads:
Affected Version Ranges: = 2.0.0.Alpha1, >= 1.3.0, < 1.3.31.Final, >= 1.4.0, < 1.4.17.Final
Fixed in: 2.0.0.Alpha2, 1.3.31.Final, 1.4.17.Final
All affected versions: 1.3.3-0.Final, 1.4.1-0.Final, 1.4.1-1.Final, 1.4.1-2.Final, 1.4.1-3.Final, 1.4.1-4.Final, 1.4.1-5.Final, 1.4.1-6.Final
All unaffected versions: