Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1ycDY1LWpwYzctOGg4cM4AA2I7

Mattermost Incorrect Authorization vulnerability

Mattermost fails to properly verify the permissions when managing/updating a bot allowing a User Manager role with user edit permissions to manage/update bots.

Permalink: https://github.com/advisories/GHSA-rp65-jpc7-8h8p
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1ycDY1LWpwYzctOGg4cM4AA2I7
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Low
Classification: General
Published: 10 months ago
Updated: 9 months ago


CVSS Score: 2.7
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N

Identifiers: GHSA-rp65-jpc7-8h8p, CVE-2023-5159
References: Blast Radius: 6.0

Affected Packages

go:github.com/mattermost/mattermost-server/v6
Dependent packages: 111
Dependent repositories: 168
Downloads:
Affected Version Ranges: < 7.8.10
Fixed in: 7.8.10
All affected versions: 6.0.0, 6.0.1, 6.0.2, 6.0.3, 6.0.4, 6.1.0, 6.1.1, 6.1.2, 6.1.3, 6.2.0, 6.2.1, 6.2.2, 6.2.3, 6.2.4, 6.2.5, 6.3.0, 6.3.1, 6.3.2, 6.3.3, 6.3.4, 6.3.5, 6.3.6, 6.3.7, 6.3.8, 6.3.9, 6.3.10, 6.4.0, 6.4.1, 6.4.2, 6.4.3, 6.5.0, 6.5.1, 6.5.2, 6.6.0, 6.6.1, 6.6.2, 6.7.0, 6.7.1, 6.7.2
All unaffected versions:
go:github.com/mattermost/mattermost/server/v8
Dependent packages: 2
Dependent repositories: 1
Downloads:
Affected Version Ranges: >= 8.0.0, < 8.0.2, = 8.1.0
Fixed in: 8.0.2, 8.1.1
All affected versions:
All unaffected versions: