Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: GSA_kwCzR0hTQS1ycDlwLTg2M2YtOWM0aM4AAdH6

Cross-site Scripting in Apache ActiveMQ

Multiple cross-site scripting (XSS) vulnerabilities in the web demos in Apache ActiveMQ before 5.8.0 allow remote attackers to inject arbitrary web script or HTML via (1) the refresh parameter to PortfolioPublishServlet.java (aka demo/portfolioPublish or Market Data Publisher), or vectors involving (2) debug logs or (3) subscribe messages in webapp/websocket/chat.js. NOTE: AMQ-4124 is covered by CVE-2012-6551.

Permalink: https://github.com/advisories/GHSA-rp9p-863f-9c4h
JSON: https://advisories.ecosyste.ms/api/v1/advisories/GSA_kwCzR0hTQS1ycDlwLTg2M2YtOWM0aM4AAdH6
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: almost 2 years ago
Updated: about 2 months ago


Identifiers: GHSA-rp9p-863f-9c4h, CVE-2012-6092
References: Repository: https://github.com/apache/activemq
Blast Radius: 0.0

Affected Packages

maven:org.apache.activemq:activemq-core
Dependent packages: 439
Dependent repositories: 7,483
Downloads:
Affected Version Ranges: < 5.8.0
Fixed in: 5.8.0
All affected versions: 4.1.1, 4.1.2, 5.0.0, 5.1.0, 5.2.0, 5.3.0, 5.3.1, 5.3.2, 5.4.0, 5.4.1, 5.4.2, 5.4.3, 5.5.0, 5.5.1, 5.6.0, 5.7.0
All unaffected versions: