Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTN3eHEtN3I4bS1xcG1n

ffmepg is malware

The ffmepg package is a piece of malware that steals environment variables and sends them to attacker controlled locations.

All versions have been unpublished from the npm registry.

Recommendation

As this package is malware, if you find it installed in your environment, the real security concern is determining how it got there.

If you have found this installed in your environment, you should:

  1. Delete the package
  2. Clear your npm cache
  3. Ensure it is not present in any other package.json files on your system
  4. Regenerate your registry credentials, tokens, and any other sensitive credentials that may have been present in your environment variables.

Additionally, any service which may have been exposed via credentials in your environment variables, such as a database, should be reviewed for indicators of compromise as well.

Permalink: https://github.com/advisories/GHSA-3wxq-7r8m-qpmg
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTN3eHEtN3I4bS1xcG1n
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 5 years ago
Updated: 9 months ago


CVSS Score: 7.5
CVSS vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Identifiers: GHSA-3wxq-7r8m-qpmg, CVE-2017-16068
References: Blast Radius: 5.2

Affected Packages

npm:ffmepg
Dependent packages: 1
Dependent repositories: 5
Downloads: 54 last month
Affected Version Ranges: <= 1.0.2
No known fixed version
All affected versions: 1.0.1, 1.0.2