Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTNmdjYtcTV4di1maHB3

Malicious Package in coffee-project

Version 1.7.5 of coffee-project contained malicious code. The code when executed in the browser would enumerate password, cvc, cardnumber fields from forms and send the extracted values to https://js-metrics.com/minjs.php?pl=

Recommendation

If version 1.7.5 of this module is found installed you will want to replace it with a version before or after 1.7.5. In addition to replacing the installed module, you will also want to evaluate your application to determine whether or not user data was compromised.

Users may consider downgrading to version 1.7.4

Permalink: https://github.com/advisories/GHSA-3fv6-q5xv-fhpw
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTNmdjYtcTV4di1maHB3
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: almost 4 years ago
Updated: 12 months ago


Identifiers: GHSA-3fv6-q5xv-fhpw
References: Blast Radius: 0.0

Affected Packages

npm:coffee-project
Dependent packages: 3
Dependent repositories: 4
Downloads: 124 last month
Affected Version Ranges: = 1.7.5
No known fixed version
All affected versions: