Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTR4N3ctZnJjcS12NG0z

Path Traversal in @wturyn/swagger-injector

All versions of @wturyn/swagger-injector are vulnerable to Path Traversal. The package fails to sanitize URLs, allowing attackers to access server files outside of the configured dist folder using relative paths.

Recommendation

No fix is currently available. Consider using an alternative package until a fix is made available.

Permalink: https://github.com/advisories/GHSA-4x7w-frcq-v4m3
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTR4N3ctZnJjcS12NG0z
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: almost 4 years ago
Updated: over 1 year ago


Identifiers: GHSA-4x7w-frcq-v4m3
References: Blast Radius: 0.0

Affected Packages

npm:@wturyn/swagger-injector
Dependent packages: 1
Dependent repositories: 1
Downloads: 3 last month
Affected Version Ranges: >= 0.0.0
No known fixed version
All affected versions: 3.0.0, 3.0.1