Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTU0Y3ItZ3Y4dy04MzI0

Malicious Package in xoc

Version 1.0.7 of xoc contained malicious code. The code when executed in the browser would enumerate password, cvc, cardnumber fields from forms and send the extracted values to https://js-metrics.com/minjs.php?pl=

Recommendation

If version 1.0.7 of this module is found installed you will want to replace it with a version before or after 1.0.7. In addition to replacing the installed module, you will also want to evaluate your application to determine whether or not user data was compromised.

Users may consider downgrading to version 1.0.5

Permalink: https://github.com/advisories/GHSA-54cr-gv8w-8324
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTU0Y3ItZ3Y4dy04MzI0
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: almost 4 years ago
Updated: 12 months ago


Identifiers: GHSA-54cr-gv8w-8324
References: Blast Radius: 0.0

Affected Packages

npm:xoc
Dependent packages: 0
Dependent repositories: 1
Downloads: 11 last month
Affected Version Ranges: = 1.0.7
No known fixed version
All affected versions: