Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTU3ZjMtZ2dobS05bWhj

jspdf vulnerable to Regular Expression Denial of Service (ReDoS)

This affects the package jspdf before 2.3.1. ReDoS is possible via the addImage function.

Permalink: https://github.com/advisories/GHSA-57f3-gghm-9mhc
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTU3ZjMtZ2dobS05bWhj
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 3 years ago
Updated: 11 months ago


CVSS Score: 7.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Identifiers: GHSA-57f3-gghm-9mhc, CVE-2021-23353
References: Repository: https://github.com/MrRio/jsPDF
Blast Radius: 32.6

Affected Packages

npm:jspdf
Dependent packages: 1,518
Dependent repositories: 21,994
Downloads: 5,414,089 last month
Affected Version Ranges: < 2.3.1
Fixed in: 2.3.1
All affected versions: 1.0.272, 1.1.135, 1.2.60, 1.2.61, 1.3.0, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5, 1.4.0, 1.4.1, 1.5.1, 1.5.2, 1.5.3, 2.0.0, 2.1.0, 2.1.1, 2.2.0, 2.3.0
All unaffected versions: 2.3.1, 2.4.0, 2.5.0, 2.5.1