An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTU4NTQtanZ4eC0yY2c5

Denial of Service in subtext

Versions of subtext >=4.1.0 are vulnerable to Denial of Service. The Content-Encoding HTTP header parser has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. Because hapi rethrows system errors (as opposed to catching expected application errors), the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.


This package is deprecated and is now maintained as @hapi/subtext. Please update your dependencies to use @hapi/subtext.

Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 3 years ago
Updated: over 1 year ago

Identifiers: GHSA-5854-jvxx-2cg9
References: Blast Radius: 0.0

Affected Packages

Dependent packages: 16
Dependent repositories: 10,764
Downloads: 215,418 last month
Affected Version Ranges: >= 4.1.0
No known fixed version
All affected versions: 4.1.0, 4.2.0, 4.2.1, 4.2.2, 4.3.0, 4.4.0, 4.4.1, 5.0.0, 5.0.1, 5.1.3, 6.0.0, 6.0.1, 6.0.3, 6.0.4, 6.0.5, 6.0.6, 6.0.7, 6.0.8, 6.0.9, 6.0.10, 6.0.11, 6.0.12