Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTV2N3Itamc5ci12cTQ0

Insecure Cryptography Algorithm in simple-crypto-js

Versions of simple-crypto-js prior to 2.3.0 use AES-CBC with PKCS#7 padding, which is vulnerable to padding oracle attacks. This may allow attackers to break the encryption and access sensitive data.

Recommendation

Upgrade to version 2.3.0 or later.

Permalink: https://github.com/advisories/GHSA-5v7r-jg9r-vq44
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTV2N3Itamc5ci12cTQ0
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: over 3 years ago
Updated: about 1 year ago


CVSS Score: 5.9
CVSS vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Identifiers: GHSA-5v7r-jg9r-vq44
References: Repository: https://github.com/danang-id/simple-crypto-js
Blast Radius: 15.3

Affected Packages

npm:simple-crypto-js
Dependent packages: 44
Dependent repositories: 396
Downloads: 76,128 last month
Affected Version Ranges: < 2.3.0
Fixed in: 2.3.0
All affected versions: 1.0.0, 1.0.1, 1.1.0, 1.1.1, 2.0.0, 2.0.2, 2.1.1, 2.1.2, 2.1.3, 2.2.0
All unaffected versions: 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.4.2, 2.5.0, 2.5.1, 3.0.0, 3.0.1