An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTY2bXYteGg2OC1oNnYy

Denial of Service in @commercial/hapi

Affected versions of @commercial/hapi are vulnerable to Denial of Service. The CORS request handler has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.


Upgrade to versions 16.8.2, 17.9.2, 18.4.1, 19.1.1 or later.

Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 3 years ago
Updated: 11 months ago

Identifiers: GHSA-66mv-xh68-h6v2

Affected Packages

Versions: >= 19.0.0, < 19.1.1, >= 18.0.0, < 18.4.1, >= 17.0.0, < 17.9.2, < 16.8.2
Fixed in: 19.1.1, 18.4.1, 17.9.2, 16.8.2