Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTZtNm0tajJobS1weHJn

Malicious Package in cicada-render

All versions of cicada-render contain malicious code. The package uploads system information to a remote server, downloads a file and executes it.

Recommendation

Any computer that has this package installed or running should be considered fully compromised. All secrets and keys stored on that computer should be rotated immediately from a different computer.

The package should be removed, but as full control of the computer may have been given to an outside entity, there is no guarantee that removing the package will remove all malicious software resulting from installing it.

Permalink: https://github.com/advisories/GHSA-6m6m-j2hm-pxrg
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTZtNm0tajJobS1weHJn
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: over 3 years ago
Updated: over 1 year ago


CVSS Score: 9.8
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Identifiers: GHSA-6m6m-j2hm-pxrg
References: Blast Radius: 0.0

Affected Packages

npm:cicada-render
Dependent packages: 1
Dependent repositories: 1
Downloads: 3 last month
Affected Version Ranges: >= 0.0.0
No known fixed version
All affected versions: