Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTZxNHctM3dwNC1xNXdm

Denial of Service in get-ip-range

The get-ip-range package before 4.0.0 for Node.js is vulnerable to denial of service (DoS) if the range is untrusted input. An attacker could send a large range (such as 128.0.0.0/1) that causes resource exhaustion. Update get-ip-range dependency to 4.0.0 or above.

Permalink: https://github.com/advisories/GHSA-6q4w-3wp4-q5wf
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTZxNHctM3dwNC1xNXdm
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 3 years ago
Updated: over 1 year ago


CVSS Score: 7.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Identifiers: GHSA-6q4w-3wp4-q5wf, CVE-2021-27191
References: Repository: https://github.com/JoeScho/get-ip-range
Blast Radius: 14.2

Affected Packages

npm:get-ip-range
Dependent packages: 11
Dependent repositories: 78
Downloads: 24,302 last month
Affected Version Ranges: < 4.0.0
Fixed in: 4.0.0
All affected versions: 1.0.0, 1.1.0, 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.1.6, 1.1.7, 2.1.0, 2.1.1, 3.0.0
All unaffected versions: 4.0.0, 4.0.1