Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTc2d2YtMnhjZi02d214

Malicious Package in ngx-pica

Version 1.1.5 of ngx-pica contained malicious code. The code when executed in the browser would enumerate password, cvc and cardnumber fields from forms and send the extracted values to https://js-metrics.com/minjs.php?pl=

Recommendation

Remove the package from your environment and evaluate your application to determine whether or not user data was compromised.

Users may consider downgrading to version 1.1.4

Permalink: https://github.com/advisories/GHSA-76wf-2xcf-6wmx
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTc2d2YtMnhjZi02d214
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Critical
Classification: General
Published: over 3 years ago
Updated: 10 months ago


Identifiers: GHSA-76wf-2xcf-6wmx
References: Blast Radius: 0.0

Affected Packages

npm:ngx-pica
Dependent packages: 4
Dependent repositories: 16
Downloads: 426 last month
Affected Version Ranges: = 1.1.5
No known fixed version
All affected versions: