Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTc4ODktcm01ai1ocGdn

Clipboard feature vulnerability allowing to inject arbitrary HTML into the editor using paste functionality

Affected packages

The vulnerability has been discovered in clipboard plugin. All plugins with clipboard plugin dependency are affected:

Impact

A potential vulnerability has been discovered in CKEditor 4 Clipboard package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version >= 4.5.2.

Patches

The problem has been recognized and patched. The fix will be available in version 4.16.2.

For more information

Email us at [email protected] if you have any questions or comments about this advisory.

Acknowledgements

The CKEditor 4 team would like to thank Anton Subbotin (skavans) for recognizing and reporting this vulnerability.

Permalink: https://github.com/advisories/GHSA-7889-rm5j-hpgg
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTc4ODktcm01ai1ocGdn
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: over 2 years ago
Updated: about 1 year ago


CVSS Score: 4.6
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N

Identifiers: GHSA-7889-rm5j-hpgg, CVE-2021-32809
References: Repository: https://github.com/ckeditor/ckeditor4
Blast Radius: 12.6

Affected Packages

npm:ckeditor4
Dependent packages: 26
Dependent repositories: 546
Downloads: 215,978 last month
Affected Version Ranges: >= 4.5.2, < 4.16.2
Fixed in: 4.16.2
All affected versions: 4.13.0, 4.13.1, 4.14.0, 4.14.1, 4.15.0, 4.15.1, 4.16.0, 4.16.1
All unaffected versions: 4.16.2, 4.17.0, 4.17.1, 4.17.2, 4.18.0, 4.19.0, 4.19.1, 4.20.0, 4.20.1, 4.20.2, 4.21.0, 4.22.0, 4.22.1, 4.23.0, 4.24.0