Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTc4Y2otZnhwaC1tODNw

Regular Expression Denial of Service (ReDoS) in ua-parser-js

ua-parser-js >= 0.7.14, fixed in 0.7.24, uses a regular expression which is vulnerable to denial of service. If an attacker sends a malicious User-Agent header, ua-parser-js will get stuck processing it for an extended period of time.

Permalink: https://github.com/advisories/GHSA-78cj-fxph-m83p
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTc4Y2otZnhwaC1tODNw
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: about 3 years ago
Updated: over 1 year ago


CVSS Score: 7.5
CVSS vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Identifiers: GHSA-78cj-fxph-m83p, CVE-2021-27292
References: Repository: https://github.com/faisalman/ua-parser-js
Blast Radius: 45.0

Affected Packages

npm:ua-parser-js
Dependent packages: 1,976
Dependent repositories: 1,003,902
Downloads: 53,706,653 last month
Affected Version Ranges: >= 0.7.14, < 0.7.24
Fixed in: 0.7.24
All affected versions: 0.7.14, 0.7.15, 0.7.16, 0.7.17, 0.7.18, 0.7.19, 0.7.20, 0.7.21, 0.7.22, 0.7.23
All unaffected versions: 0.3.0, 0.3.1, 0.4.0, 0.4.1, 0.4.3, 0.4.4, 0.4.6, 0.4.7, 0.4.13, 0.4.15, 0.5.1, 0.5.2, 0.5.3, 0.5.11, 0.5.12, 0.5.15, 0.5.20, 0.5.22, 0.5.23, 0.5.25, 0.5.27, 0.6.0, 0.6.2, 0.7.0, 0.7.1, 0.7.3, 0.7.4, 0.7.6, 0.7.7, 0.7.9, 0.7.10, 0.7.11, 0.7.12, 0.7.13, 0.7.24, 0.7.25, 0.7.26, 0.7.27, 0.7.28, 0.7.30, 0.7.31, 0.7.32, 0.7.33, 0.7.34, 0.7.35, 0.7.36, 0.7.37, 0.7.38, 0.8.1, 1.0.1, 1.0.2, 1.0.32, 1.0.33, 1.0.34, 1.0.35, 1.0.36, 1.0.37, 1.0.38