Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLThmdzQteGg4My0zajZx

Cross-Site Scripting in diagram-js

Versions of diagram-js prior to 3.3.1 (for 3.x) and 2.6.2 (for 2.x) are vulnerable to Cross-Site Scripting. The package fails to escape output of user-controlled input in search-pad, allowing attackers to execute arbitrary JavaScript.

Recommendation

If you are using diagram-js 3.x, upgrade to version 3.3.1.
If you are using diagram-js 2.x, upgrade to version 2.6.2.

Permalink: https://github.com/advisories/GHSA-8fw4-xh83-3j6q
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLThmdzQteGg4My0zajZx
Source: GitHub Advisory Database
Origin: Unspecified
Severity: Moderate
Classification: General
Published: almost 4 years ago
Updated: 10 months ago


Identifiers: GHSA-8fw4-xh83-3j6q
References: Repository: https://github.com/bpmn-io/diagram-js
Blast Radius: 0.0

Affected Packages

npm:diagram-js
Dependent packages: 251
Dependent repositories: 1,030
Downloads: 371,085 last month
Affected Version Ranges: >= 3.0.0, < 3.3.1, < 2.6.2
Fixed in: 3.3.1, 2.6.2
All affected versions: 0.0.1, 0.0.2, 0.0.3, 0.1.0, 0.2.0, 0.3.0, 0.4.0, 0.5.0, 0.5.1, 0.5.2, 0.6.0, 0.7.0, 0.8.0, 0.8.1, 0.9.0, 0.9.1, 0.9.2, 0.9.3, 0.9.4, 0.10.0, 0.10.1, 0.10.2, 0.11.0, 0.12.0, 0.12.1, 0.13.0, 0.13.1, 0.13.2, 0.13.3, 0.14.0, 0.14.1, 0.14.2, 0.15.0, 0.15.1, 0.15.2, 0.15.3, 0.15.4, 0.16.0, 0.16.1, 0.16.2, 0.16.3, 0.17.0, 0.18.0, 0.18.1, 0.18.2, 0.18.3, 0.18.4, 0.19.0, 0.19.1, 0.19.2, 0.19.3, 0.19.4, 0.19.5, 0.19.6, 0.20.0, 0.21.0, 0.21.1, 0.22.0, 0.22.1, 0.22.2, 0.22.3, 0.22.4, 0.22.5, 0.23.0, 0.24.0, 0.25.0, 0.25.1, 0.26.0, 0.27.0, 0.27.1, 0.27.2, 0.28.0, 0.28.1, 0.28.2, 0.28.3, 0.29.0, 0.29.1, 0.29.2, 0.30.0, 0.31.0, 0.31.1, 1.0.0, 1.0.1, 1.1.0, 1.1.1, 1.2.0, 1.2.1, 1.2.2, 1.3.0, 1.3.1, 1.4.0, 2.0.0, 2.1.0, 2.1.1, 2.2.0, 2.3.0, 2.4.0, 2.4.1, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 3.0.0, 3.0.1, 3.0.2, 3.1.0, 3.1.1, 3.1.2, 3.1.3, 3.2.0, 3.3.0
All unaffected versions: 2.6.2, 3.3.1, 4.0.0, 4.0.1, 4.0.2, 4.0.3, 5.0.0, 5.0.1, 5.0.2, 5.1.0, 5.1.1, 6.0.0, 6.0.1, 6.0.2, 6.1.0, 6.2.0, 6.2.1, 6.2.2, 6.3.0, 6.4.0, 6.4.1, 6.5.0, 6.6.0, 6.6.1, 6.7.0, 6.7.1, 6.8.0, 6.8.1, 6.8.2, 7.0.0, 7.1.0, 7.2.0, 7.2.1, 7.2.2, 7.2.3, 7.3.0, 7.3.1, 7.4.0, 7.4.1, 7.5.0, 7.6.0, 7.6.1, 7.6.2, 7.6.3, 7.7.0, 7.8.0, 7.8.1, 7.8.2, 7.8.3, 7.9.0, 8.0.0, 8.0.1, 8.0.2, 8.1.0, 8.1.1, 8.1.2, 8.2.0, 8.2.1, 8.2.2, 8.3.0, 8.4.0, 8.5.0, 8.6.0, 8.7.0, 8.7.1, 8.8.0, 8.9.0, 9.0.0, 9.1.0, 10.0.0, 11.0.0, 11.1.0, 11.1.1, 11.2.0, 11.2.1, 11.3.0, 11.4.0, 11.4.1, 11.4.2, 11.4.3, 11.4.4, 11.5.0, 11.6.0, 11.7.0, 11.8.0, 11.9.0, 11.9.1, 11.10.0, 11.11.0, 11.12.0, 11.13.0, 11.13.1, 12.0.0, 12.0.1, 12.0.2, 12.1.0, 12.1.1, 12.2.0, 12.3.0, 12.4.0, 12.5.0, 12.6.0, 12.7.0, 12.7.1, 12.7.2, 12.7.3, 12.8.0, 12.8.1, 13.0.0, 13.1.0, 13.2.0, 13.3.0, 13.4.0, 14.0.0, 14.1.0, 14.1.1, 14.2.0, 14.3.0, 14.3.1, 14.3.2, 14.3.3, 14.4.0, 14.4.1, 14.4.2, 14.5.0, 14.5.1, 14.5.2, 14.5.3, 14.5.4, 14.6.0, 14.7.0, 14.7.1, 14.7.2, 14.8.0