Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTl2cnctbTg4Zy13NzVx

Denial of Service in @hapi/accept

Versions of @hapi/accept prior to 3.2.4 or 5.0.1 are vulnerable to Denial of Service. The Accept-Encoding HTTP header parser has a vulnerability which will cause the function to throw a system error if the header contains some invalid values. Because hapi rethrows system errors (as opposed to catching expected application errors), the error is thrown all the way up the stack. If no unhandled exception handler is available, the application will exist, allowing an attacker to shut down services.

Recommendation

Upgrade to version 3.2.4 or 5.0.1.

Permalink: https://github.com/advisories/GHSA-9vrw-m88g-w75q
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTl2cnctbTg4Zy13NzVx
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 3 years ago
Updated: over 1 year ago


Identifiers: GHSA-9vrw-m88g-w75q
References: Blast Radius: 0.0

Affected Packages

npm:@hapi/accept
Dependent packages: 89
Dependent repositories: 109,454
Downloads: 4,221,076 last month
Affected Version Ranges: >= 4.0.0, < 5.0.1, >= 3.2.0, < 3.2.4
Fixed in: 5.0.1, 3.2.4
All affected versions: 3.2.0, 3.2.1, 3.2.2, 3.2.3, 4.0.0, 4.0.1, 5.0.0
All unaffected versions: 3.2.4, 5.0.1, 5.0.2, 6.0.0, 6.0.1, 6.0.2, 6.0.3