Ecosyste.ms: Advisories

An open API service providing security vulnerability metadata for many open source software ecosystems.

Security Advisories: MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTlyN2gtNjYzOS12NW13

Cross-Site Scripting in bootstrap-select

Versions of bootstrap-select prior to 1.13.6 are vulnerable to Cross-Site Scripting (XSS). The package does not escape title values on <option> tags. This may allow attackers to execute arbitrary JavaScript in a victim's browser.

Recommendation

Upgrade to version 1.13.6 or later.

Permalink: https://github.com/advisories/GHSA-9r7h-6639-v5mw
JSON: https://advisories.ecosyste.ms/api/v1/advisories/MDE2OlNlY3VyaXR5QWR2aXNvcnlHSFNBLTlyN2gtNjYzOS12NW13
Source: GitHub Advisory Database
Origin: Unspecified
Severity: High
Classification: General
Published: over 3 years ago
Updated: over 1 year ago


Identifiers: GHSA-9r7h-6639-v5mw
References: Repository: https://github.com/dimpu/ngx-md
Blast Radius: 0.0

Affected Packages

npm:bootstrap-select
Dependent packages: 332
Dependent repositories: 4,970
Downloads: 444,474 last month
Affected Version Ranges: < 1.13.6
Fixed in: 1.13.6
All affected versions: 1.6.2, 1.6.3, 1.7.0, 1.7.1, 1.7.2, 1.7.3, 1.7.4, 1.7.5, 1.7.7, 1.8.0, 1.8.1, 1.9.2, 1.9.3, 1.9.4, 1.10.0, 1.11.0, 1.11.1, 1.11.2, 1.12.0, 1.12.1, 1.12.2, 1.12.3, 1.12.4, 1.13.0, 1.13.1, 1.13.2, 1.13.3, 1.13.4, 1.13.5
All unaffected versions: 1.13.6, 1.13.7, 1.13.8, 1.13.9, 1.13.10, 1.13.11, 1.13.12, 1.13.13, 1.13.14, 1.13.15, 1.13.16, 1.13.17, 1.13.18